Mercurial > dropbear
comparison debian/rules @ 524:3c3cef8a32e6 maemo
- Make it do the postinst files etc for dropbear-server
- Improve the NO_START message
author | Matt Johnston <matt@ucc.asn.au> |
---|---|
date | Tue, 18 Nov 2008 23:15:24 +0000 |
parents | 4ff1bf0345c9 |
children | 9f5e2616c064 |
comparison
equal
deleted
inserted
replaced
523:4ff1bf0345c9 | 524:3c3cef8a32e6 |
---|---|
86 $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* | 86 $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* |
87 | 87 |
88 install -d -m0755 '$(DIR)'/DEBIAN | 88 install -d -m0755 '$(DIR)'/DEBIAN |
89 test '$(CC)' != 'gcc' || \ | 89 test '$(CC)' != 'gcc' || \ |
90 dpkg-shlibdeps '$(DIR)'/usr/sbin/* | 90 dpkg-shlibdeps '$(DIR)'/usr/sbin/* |
91 dpkg-gencontrol -isp -pdropbear-server -P'$(DIR)' | |
92 dpkg -b '$(DIR)' .. | |
93 | 91 |
94 install-client: DIR=$(shell pwd)/debian/dropbear-client | 92 install-client: DIR=$(shell pwd)/debian/dropbear-client |
95 install-client: deb-checkdir deb-checkuid config.status | 93 install-client: deb-checkdir deb-checkuid config.status |
96 rm -f '$(DIR)' | 94 rm -f '$(DIR)' |
97 $(MAKE) clean | 95 $(MAKE) clean |
104 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* | 102 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* |
105 | 103 |
106 install -d -m0755 '$(DIR)'/DEBIAN | 104 install -d -m0755 '$(DIR)'/DEBIAN |
107 test '$(CC)' != 'gcc' || \ | 105 test '$(CC)' != 'gcc' || \ |
108 dpkg-shlibdeps '$(DIR)'/usr/bin/* | 106 dpkg-shlibdeps '$(DIR)'/usr/bin/* |
109 dpkg-gencontrol -isp -pdropbear-client -P'$(DIR)' | |
110 dpkg -b '$(DIR)' .. | |
111 | 107 |
112 install-common: DIR=$(shell pwd)/debian/dropbear-common | 108 install-common: DIR=$(shell pwd)/debian/dropbear-common |
113 install-common: deb-checkdir deb-checkuid config.status | 109 install-common: deb-checkdir deb-checkuid config.status |
114 rm -f '$(DIR)' | 110 rm -f '$(DIR)' |
115 $(MAKE) clean | 111 $(MAKE) clean |
129 '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* | 125 '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* |
130 | 126 |
131 install -d -m0755 '$(DIR)'/DEBIAN | 127 install -d -m0755 '$(DIR)'/DEBIAN |
132 test '$(CC)' != 'gcc' || \ | 128 test '$(CC)' != 'gcc' || \ |
133 dpkg-shlibdeps '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* | 129 dpkg-shlibdeps '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* |
134 dpkg-gencontrol -isp -pdropbear-common -P'$(DIR)' | |
135 dpkg -b '$(DIR)' .. | |
136 | 130 |
137 install-scp: DIR=$(shell pwd)/debian/dropbear-scp | 131 install-scp: DIR=$(shell pwd)/debian/dropbear-scp |
138 install-scp: deb-checkdir deb-checkuid config.status | 132 install-scp: deb-checkdir deb-checkuid config.status |
139 rm -f '$(DIR)' | 133 rm -f '$(DIR)' |
140 $(MAKE) clean | 134 $(MAKE) clean |
144 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* | 138 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* |
145 | 139 |
146 install -d -m0755 '$(DIR)'/DEBIAN | 140 install -d -m0755 '$(DIR)'/DEBIAN |
147 test '$(CC)' != 'gcc' || \ | 141 test '$(CC)' != 'gcc' || \ |
148 dpkg-shlibdeps '$(DIR)'/usr/bin/* | 142 dpkg-shlibdeps '$(DIR)'/usr/bin/* |
149 dpkg-gencontrol -isp -pdropbear-scp -P'$(DIR)' | |
150 dpkg -b '$(DIR)' .. | |
151 | 143 |
152 install-multi: DIR=$(shell pwd)/debian/dropbear | 144 install-multi: DIR=$(shell pwd)/debian/dropbear |
153 install-multi: deb-checkdir deb-checkuid config.status | 145 install-multi: deb-checkdir deb-checkuid config.status |
154 rm -f '$(DIR)' | 146 rm -f '$(DIR)' |
155 $(MAKE) clean | 147 $(MAKE) clean |
186 | 178 |
187 install -d -m0755 '$(DIR)'/DEBIAN | 179 install -d -m0755 '$(DIR)'/DEBIAN |
188 test '$(CC)' != 'gcc' || \ | 180 test '$(CC)' != 'gcc' || \ |
189 dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \ | 181 dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \ |
190 '$(DIR)'/usr/lib/dropbear/* | 182 '$(DIR)'/usr/lib/dropbear/* |
191 dpkg-gencontrol -isp -pdropbear -P'$(DIR)' | |
192 dpkg -b '$(DIR)' .. | |
193 | 183 |
194 install: install-client install-server install-common install-multi install-scp | 184 install: install-client install-server install-common install-multi install-scp |
195 binary-indep: | 185 binary-indep: |
196 | 186 |
197 binary-arch: install dropbear.deb | 187 binary-arch: install dropbear.deb dropbear-server.deb dropbear-common.deb dropbear-scp.deb dropbear-client.deb |
188 dpkg-gencontrol -isp -pdropbear -P'$(shell pwd)/debian'/dropbear | |
189 dpkg-gencontrol -isp -pdropbear-server -P'$(shell pwd)/debian'/dropbear-server | |
190 dpkg-gencontrol -isp -pdropbear-client -P'$(shell pwd)/debian'/dropbear-client | |
191 dpkg-gencontrol -isp -pdropbear-common -P'$(shell pwd)/debian'/dropbear-common | |
192 dpkg-gencontrol -isp -pdropbear-scp -P'$(shell pwd)/debian'/dropbear-scp | |
193 dpkg -b '$(shell pwd)/debian'/dropbear .. | |
194 dpkg -b '$(shell pwd)/debian'/dropbear-server .. | |
195 dpkg -b '$(shell pwd)/debian'/dropbear-common .. | |
196 dpkg -b '$(shell pwd)/debian'/dropbear-scp .. | |
197 dpkg -b '$(shell pwd)/debian'/dropbear-client .. | |
198 | 198 |
199 binary: binary-arch binary-indep | 199 binary: binary-arch binary-indep |
200 | 200 |
201 .PHONY: patch build clean install binary-indep binary-arch binary | 201 .PHONY: patch build clean install binary-indep binary-arch binary |
202 | 202 |