Mercurial > dropbear
comparison debian/dropbear.postinst @ 218:3ee0c2f85e1e
* patch up to date with debian 0.45-3 diff
author | Matt Johnston <matt@ucc.asn.au> |
---|---|
date | Fri, 08 Jul 2005 13:27:28 +0000 |
parents | b0316ce64e4b |
children | 654bc8327787 |
comparison
equal
deleted
inserted
replaced
177:2098857ab826 | 218:3ee0c2f85e1e |
---|---|
1 #!/bin/sh | 1 #!/bin/sh |
2 set -e | 2 set -e |
3 | 3 |
4 test "$1" = 'configure' || exit 0 | 4 test "$1" = 'configure' || exit 0 |
5 test -n "$2" || chown log /etc/dropbear/log/main || true | |
6 | 5 |
7 if test ! -e /etc/dropbear/dropbear_rsa_host_key; then | 6 if test ! -e /etc/dropbear/dropbear_rsa_host_key; then |
8 if test -f /etc/ssh/ssh_host_rsa_key; then | 7 if test -f /etc/ssh/ssh_host_rsa_key; then |
9 echo "Converting existing OpenSSH RSA host key to Dropbear format." | 8 echo "Converting existing OpenSSH RSA host key to Dropbear format." |
10 /usr/lib/dropbear/dropbearconvert openssh dropbear \ | 9 /usr/lib/dropbear/dropbearconvert openssh dropbear \ |
59 fi | 58 fi |
60 | 59 |
61 if test -x /etc/init.d/dropbear; then | 60 if test -x /etc/init.d/dropbear; then |
62 update-rc.d dropbear defaults >/dev/null | 61 update-rc.d dropbear defaults >/dev/null |
63 if test -x /usr/sbin/invoke-rc.d; then | 62 if test -x /usr/sbin/invoke-rc.d; then |
64 invoke-rc.d dropbear start | 63 invoke-rc.d dropbear restart |
65 else | 64 else |
66 /etc/init.d/dropbear start | 65 /etc/init.d/dropbear restart |
67 fi | 66 fi |
68 fi | 67 fi |