Mercurial > dropbear
comparison debian/rules @ 218:3ee0c2f85e1e
* patch up to date with debian 0.45-3 diff
author | Matt Johnston <matt@ucc.asn.au> |
---|---|
date | Fri, 08 Jul 2005 13:27:28 +0000 |
parents | 95f4bc4bcd58 |
children | 654bc8327787 |
comparison
equal
deleted
inserted
replaced
177:2098857ab826 | 218:3ee0c2f85e1e |
---|---|
14 CFLAGS +=-O0 | 14 CFLAGS +=-O0 |
15 else | 15 else |
16 CFLAGS +=-O2 | 16 CFLAGS +=-O2 |
17 endif | 17 endif |
18 | 18 |
19 CONFFLAGS = | |
19 CC =gcc | 20 CC =gcc |
20 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS))) | 21 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS))) |
21 CC =diet -v -Os gcc | 22 CONFFLAGS =--disable-zlib |
23 CC =diet -v -Os gcc -nostdinc | |
22 endif | 24 endif |
23 | 25 |
24 DIR=`pwd`/debian/dropbear | 26 DIR =$(shell pwd)/debian/dropbear |
25 | 27 |
26 patch: deb-checkdir patch-stamp | 28 patch: deb-checkdir patch-stamp |
27 patch-stamp: | 29 patch-stamp: |
28 # no patches for now | 30 for i in `ls -1 debian/diff/*.diff || :`; do \ |
29 # for i in debian/diff/*.diff; do patch -p0 <$$i || exit 1; done | 31 patch -p0 <$$i || exit 1; \ |
32 done | |
30 touch patch-stamp | 33 touch patch-stamp |
31 | 34 |
32 config.status: patch-stamp configure | 35 config.status: patch-stamp configure |
33 CFLAGS="$(CFLAGS)"' -DSFTPSERVER_PATH="\"/usr/lib/sftp-server\""' \ | 36 CC='$(CC)' \ |
34 ./configure --host="$(DEB_HOST_GNU_TYPE)" \ | 37 CFLAGS='$(CFLAGS)'' -DSFTPSERVER_PATH="\"/usr/lib/sftp-server\""' \ |
35 --build="$(DEB_BUILD_GNU_TYPE)" --prefix=/usr \ | 38 ./configure --host='$(DEB_HOST_GNU_TYPE)' \ |
36 --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info | 39 --build='$(DEB_BUILD_GNU_TYPE)' --prefix=/usr \ |
40 --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \ | |
41 $(CONFFLAGS) | |
37 | 42 |
38 build: deb-checkdir build-stamp | 43 build: deb-checkdir build-stamp |
39 build-stamp: config.status | 44 build-stamp: config.status |
40 $(MAKE) CC="$(CC)" LD="$(CC)" | 45 $(MAKE) CC='$(CC)' LD='$(CC)' |
41 touch build-stamp | 46 touch build-stamp |
42 | 47 |
43 clean: deb-checkdir deb-checkuid | 48 clean: deb-checkdir deb-checkuid |
44 -$(MAKE) distclean | 49 -$(MAKE) distclean |
45 # test ! -e patch-stamp || \ | 50 test ! -e patch-stamp || \ |
46 # for i in debian/diff/*.diff; do patch -p0 -R <$$i; done | 51 for i in `ls -1r debian/diff/*.diff || :`; do \ |
52 patch -p0 -R <$$i; \ | |
53 done | |
47 rm -f patch-stamp build-stamp config.log config.status | 54 rm -f patch-stamp build-stamp config.log config.status |
48 rm -rf "$(DIR)" | 55 rm -rf '$(DIR)' |
49 rm -f debian/files debian/substvars debian/copyright changelog | 56 rm -f debian/files debian/substvars debian/copyright changelog |
50 | 57 |
51 install: deb-checkdir deb-checkuid build-stamp | 58 install: deb-checkdir deb-checkuid build-stamp |
52 rm -rf "$(DIR)" | 59 rm -rf '$(DIR)' |
53 install -d -m0755 "$(DIR)"/etc/dropbear | 60 install -d -m0755 '$(DIR)'/etc/dropbear |
54 # programs | 61 # programs |
55 install -d -m0755 "$(DIR)"/usr/sbin | 62 install -d -m0755 '$(DIR)'/usr/sbin |
56 install -m0755 dropbear "$(DIR)"/usr/sbin/dropbear | 63 install -m0755 dropbear '$(DIR)'/usr/sbin/dropbear |
57 install -d -m0755 "$(DIR)"/usr/bin | 64 install -d -m0755 '$(DIR)'/usr/bin |
58 install -m0755 dbclient "$(DIR)"/usr/bin/dbclient | 65 install -m0755 dbclient '$(DIR)'/usr/bin/dbclient |
59 install -m0755 dropbearkey "$(DIR)"/usr/bin/dropbearkey | 66 install -m0755 dropbearkey '$(DIR)'/usr/bin/dropbearkey |
60 install -d -m0755 "$(DIR)"/usr/lib/dropbear | 67 install -d -m0755 '$(DIR)'/usr/lib/dropbear |
61 install -m0755 dropbearconvert \ | 68 install -m0755 dropbearconvert \ |
62 "$(DIR)"/usr/lib/dropbear/dropbearconvert | 69 '$(DIR)'/usr/lib/dropbear/dropbearconvert |
63 $(STRIP) -R .comment -R .note "$(DIR)"/usr/sbin/* \ | 70 $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* \ |
64 "$(DIR)"/usr/bin/* "$(DIR)"/usr/lib/dropbear/* | 71 '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* |
65 # init and run scripts | 72 # init and run scripts |
66 install -d -m0755 "$(DIR)"/etc/init.d | 73 install -d -m0755 '$(DIR)'/etc/init.d |
67 install -m0755 debian/dropbear.init "$(DIR)"/etc/init.d/dropbear | 74 install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear |
68 install -m0755 debian/service/run "$(DIR)"/etc/dropbear/run | 75 install -m0755 debian/service/run '$(DIR)'/etc/dropbear/run |
69 install -d -m0755 "$(DIR)"/etc/dropbear/log | 76 install -d -m0755 '$(DIR)'/etc/dropbear/log |
70 install -m0755 debian/service/log "$(DIR)"/etc/dropbear/log/run | 77 install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run |
71 ln -s /var/log/dropbear "$(DIR)"/etc/dropbear/log/main | 78 ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main |
72 ln -s /var/run/dropbear "$(DIR)"/etc/dropbear/supervise | 79 ln -s /var/run/dropbear '$(DIR)'/etc/dropbear/supervise |
73 ln -s /var/run/dropbear.log "$(DIR)"/etc/dropbear/log/supervise | 80 ln -s /var/run/dropbear.log '$(DIR)'/etc/dropbear/log/supervise |
74 # man pages | 81 # man pages |
75 install -d -m0755 "$(DIR)"/usr/share/man/man8 | 82 install -d -m0755 '$(DIR)'/usr/share/man/man8 |
76 for i in dropbear.8 dropbearkey.8; do \ | 83 for i in dropbear.8 dropbearkey.8; do \ |
77 install -m644 $$i "$(DIR)"/usr/share/man/man8/ || exit 1; \ | 84 install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \ |
78 done | 85 done |
79 gzip -9 "$(DIR)"/usr/share/man/man8/*.8 | 86 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 |
87 install -d -m0755 '$(DIR)'/usr/share/man/man1 | |
88 install -m644 debian/dbclient.1 '$(DIR)'/usr/share/man/man1/ | |
89 gzip -9 '$(DIR)'/usr/share/man/man1/*.1 | |
80 # copyright, changelog | 90 # copyright, changelog |
81 cat debian/copyright.in LICENSE >debian/copyright | 91 cat debian/copyright.in LICENSE >debian/copyright |
82 ln -s CHANGES changelog | 92 test -r changelog || ln -s CHANGES changelog |
83 | 93 |
84 binary-indep: | 94 binary-indep: |
85 | 95 |
86 binary-arch: install dropbear.deb | 96 binary-arch: install dropbear.deb |
87 test "$(CC)" != 'gcc' || \ | 97 test '$(CC)' != 'gcc' || \ |
88 dpkg-shlibdeps "$(DIR)"/usr/sbin/* "$(DIR)"/usr/bin/* \ | 98 dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \ |
89 "$(DIR)"/usr/lib/dropbear/* | 99 '$(DIR)'/usr/lib/dropbear/* |
90 dpkg-gencontrol -isp -pdropbear -P"$(DIR)" | 100 dpkg-gencontrol -isp -pdropbear -P'$(DIR)' |
91 dpkg -b "$(DIR)" .. | 101 dpkg -b '$(DIR)' .. |
92 | 102 |
93 binary: binary-arch binary-indep | 103 binary: binary-arch binary-indep |
94 | 104 |
95 .PHONY: patch build clean install binary-indep binary-arch binary | 105 .PHONY: patch build clean install binary-indep binary-arch binary |
96 | 106 |