Mercurial > dropbear
comparison debian/rules @ 835:4095b6d7c9fc ecc
Merge in changes from the past couple of releases
author | Matt Johnston <matt@ucc.asn.au> |
---|---|
date | Fri, 18 Oct 2013 21:38:01 +0800 |
parents | 7b68e581985f |
children |
comparison
equal
deleted
inserted
replaced
807:75509065db53 | 835:4095b6d7c9fc |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 | |
3 export DEB_BUILD_MAINT_OPTIONS = hardening=+all | |
4 DPKG_EXPORT_BUILDFLAGS = 1 | |
5 include /usr/share/dpkg/buildflags.mk | |
2 | 6 |
3 #export DH_OPTIONS | 7 #export DH_OPTIONS |
4 DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) | 8 DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) |
5 DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | 9 DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) |
6 | 10 |
7 STRIP =strip | 11 STRIP =strip |
8 ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) | 12 ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
9 STRIP =: nostrip | 13 STRIP =: nostrip |
10 endif | |
11 | |
12 CFLAGS =-Wall -g | |
13 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) | |
14 CFLAGS +=-O0 | |
15 else | |
16 CFLAGS +=-O2 | |
17 endif | 14 endif |
18 | 15 |
19 CONFFLAGS = | 16 CONFFLAGS = |
20 CC =gcc | 17 CC =gcc |
21 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS))) | 18 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS))) |
77 install -d -m0755 '$(DIR)'/etc/dropbear/log | 74 install -d -m0755 '$(DIR)'/etc/dropbear/log |
78 install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run | 75 install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run |
79 ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main | 76 ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main |
80 # man pages | 77 # man pages |
81 install -d -m0755 '$(DIR)'/usr/share/man/man8 | 78 install -d -m0755 '$(DIR)'/usr/share/man/man8 |
82 for i in dropbear.8 dropbearkey.8; do \ | 79 install -d -m0755 '$(DIR)'/usr/share/man/man1 |
83 install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \ | 80 install -m644 dropbear.8 '$(DIR)'/usr/share/man/man8/ |
81 for i in dbclient.1 dropbearkey.1 dropbearconvert.1; do \ | |
82 install -m644 $$i '$(DIR)'/usr/share/man/man1/ || exit 1; \ | |
84 done | 83 done |
85 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 | 84 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 |
86 install -d -m0755 '$(DIR)'/usr/share/man/man1 | |
87 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/ | |
88 gzip -9 '$(DIR)'/usr/share/man/man1/*.1 | 85 gzip -9 '$(DIR)'/usr/share/man/man1/*.1 |
89 # copyright, changelog | 86 # copyright, changelog |
90 cat debian/copyright.in LICENSE >debian/copyright | 87 cat debian/copyright.in LICENSE >debian/copyright |
91 test -r changelog || ln -s CHANGES changelog | 88 test -r changelog || ln -s CHANGES changelog |
92 | 89 |