comparison debian/rules @ 824:7b68e581985f DROPBEAR_2013.59

Fix up debian build
author Matt Johnston <matt@ucc.asn.au>
date Fri, 04 Oct 2013 22:22:35 +0800
parents cb3cfcea1c8d
children
comparison
equal deleted inserted replaced
823:cb3cfcea1c8d 824:7b68e581985f
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2
3 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
4 DPKG_EXPORT_BUILDFLAGS = 1
5 include /usr/share/dpkg/buildflags.mk
2 6
3 #export DH_OPTIONS 7 #export DH_OPTIONS
4 DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE) 8 DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
5 DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) 9 DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
6 10
7 STRIP =strip 11 STRIP =strip
8 ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) 12 ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
9 STRIP =: nostrip 13 STRIP =: nostrip
10 endif
11
12 CFLAGS =-Wall -g
13 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
14 CFLAGS +=-O0
15 else
16 CFLAGS +=-O2
17 endif 14 endif
18 15
19 CONFFLAGS = 16 CONFFLAGS =
20 CC =gcc 17 CC =gcc
21 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS))) 18 ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS)))