comparison debian/rules @ 549:7f552ea5bf72 maemo

merge of '3450609f92928775614418f40dd44ed5393d9de4' and '6a58c90036c543b4d992489843a999156f665e61'
author Matt Johnston <matt@ucc.asn.au>
date Wed, 01 Jul 2009 05:14:51 +0000
parents b0668a7f76d9 9f5e2616c064
children
comparison
equal deleted inserted replaced
548:b0668a7f76d9 549:7f552ea5bf72
35 CFLAGS='$(CFLAGS)'' -DSFTPSERVER_PATH="\"/usr/lib/sftp-server\""' \ 35 CFLAGS='$(CFLAGS)'' -DSFTPSERVER_PATH="\"/usr/lib/sftp-server\""' \
36 ./configure --host='$(DEB_HOST_GNU_TYPE)' \ 36 ./configure --host='$(DEB_HOST_GNU_TYPE)' \
37 --build='$(DEB_BUILD_GNU_TYPE)' --prefix=/usr \ 37 --build='$(DEB_BUILD_GNU_TYPE)' --prefix=/usr \
38 --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \ 38 --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \
39 $(CONFFLAGS) 39 $(CONFFLAGS)
40 $(MAKE) clean
40 41
41 build: deb-checkdir build-stamp 42 build: deb-checkdir build-stamp
42 build-stamp: config.status 43 build-stamp: config.status
43 $(MAKE) CC='$(CC)' LD='$(CC)' 44 $(MAKE) CC='$(CC)' LD='$(CC)'
44 touch build-stamp 45 touch build-stamp
53 done 54 done
54 rm -f patch-stamp build-stamp config.log config.status 55 rm -f patch-stamp build-stamp config.log config.status
55 rm -rf '$(DIR)' 56 rm -rf '$(DIR)'
56 rm -rf '$(DIR)'-client 57 rm -rf '$(DIR)'-client
57 rm -rf '$(DIR)'-server 58 rm -rf '$(DIR)'-server
58 rm -rf '$(DIR)'-common 59 rm -rf '$(DIR)'-keyutils
59 rm -rf '$(DIR)'-scp 60 rm -rf '$(DIR)'-scp
60 rm -f debian/files debian/substvars debian/copyright changelog 61 rm -f debian/files debian/substvars debian/copyright changelog
61 62
62 install-server: DIR=$(shell pwd)/debian/dropbear-server 63 install-server: DIR=$(shell pwd)/debian/dropbear-server
63 install-server: deb-checkdir deb-checkuid config.status 64 install-server: deb-checkdir deb-checkuid config.status
64 rm -f '$(DIR)' 65 rm -f '$(DIR)'
65 $(MAKE) clean 66 rm *.o
66 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dropbear dropbear 67 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbear dropbearkey dropbearconvert" MULTI=1
67 install -d -m0755 '$(DIR)'/etc/dropbear 68 install -d -m0755 '$(DIR)'/etc/dropbear
68 # programs 69 # programs
70 install -d -m0755 '$(DIR)'/usr/bin
69 install -d -m0755 '$(DIR)'/usr/sbin 71 install -d -m0755 '$(DIR)'/usr/sbin
70 install -m0755 dropbear '$(DIR)'/usr/sbin/dropbear 72 install -d -m0755 '$(DIR)'/usr/lib/dropbear
73 install -m0755 dropbearmulti \
74 '$(DIR)'/usr/lib/dropbear/dropbearmulti
75 ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dropbearkey
76 ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/sbin/dropbear
77 ln -s dropbearmulti '$(DIR)'/usr/lib/dropbear/dropbearconvert
71 # init and run scripts 78 # init and run scripts
72 install -d -m0755 '$(DIR)'/etc/init.d 79 install -d -m0755 '$(DIR)'/etc/init.d
73 install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear 80 install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear
74 install -m0755 debian/service/run '$(DIR)'/etc/dropbear/run 81 install -m0755 debian/service/run '$(DIR)'/etc/dropbear/run
75 install -d -m0755 '$(DIR)'/etc/dropbear/log 82 install -d -m0755 '$(DIR)'/etc/dropbear/log
81 done 88 done
82 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 89 gzip -9 '$(DIR)'/usr/share/man/man8/*.8
83 # copyright, changelog 90 # copyright, changelog
84 cat debian/copyright.in LICENSE > debian/copyright 91 cat debian/copyright.in LICENSE > debian/copyright
85 test -r changelog || ln -s CHANGES changelog 92 test -r changelog || ln -s CHANGES changelog
86 $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* 93 $(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
87 94
88 install -d -m0755 '$(DIR)'/DEBIAN 95 install -d -m0755 '$(DIR)'/DEBIAN
89 test '$(CC)' != 'gcc' || \ 96 test '$(CC)' != 'gcc' || \
90 dpkg-shlibdeps '$(DIR)'/usr/sbin/* 97 dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
91 dpkg-gencontrol -isp -pdropbear-server -P'$(DIR)'
92 dpkg -b '$(DIR)' ..
93 98
94 install-client: DIR=$(shell pwd)/debian/dropbear-client 99 install-client: DIR=$(shell pwd)/debian/dropbear-client
95 install-client: deb-checkdir deb-checkuid config.status 100 install-client: deb-checkdir deb-checkuid config.status
96 rm -f '$(DIR)' 101 rm -f '$(DIR)'
97 $(MAKE) clean 102 rm *.o
98 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dbclient dbclient 103 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dbclient dbclient
99 install -d -m0755 '$(DIR)'/usr/bin 104 install -d -m0755 '$(DIR)'/usr/bin
100 install -m0755 dbclient '$(DIR)'/usr/bin/dbclient 105 install -m0755 dbclient '$(DIR)'/usr/bin/dbclient
101 install -d -m0755 '$(DIR)'/usr/share/man/man1 106 install -d -m0755 '$(DIR)'/usr/share/man/man1
102 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/ 107 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/
104 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* 109 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/*
105 110
106 install -d -m0755 '$(DIR)'/DEBIAN 111 install -d -m0755 '$(DIR)'/DEBIAN
107 test '$(CC)' != 'gcc' || \ 112 test '$(CC)' != 'gcc' || \
108 dpkg-shlibdeps '$(DIR)'/usr/bin/* 113 dpkg-shlibdeps '$(DIR)'/usr/bin/*
109 dpkg-gencontrol -isp -pdropbear-client -P'$(DIR)' 114
110 dpkg -b '$(DIR)' .. 115 install-keyutils: DIR=$(shell pwd)/debian/dropbear-keyutils
111 116 install-keyutils: deb-checkdir deb-checkuid config.status
112 install-common: DIR=$(shell pwd)/debian/dropbear-common 117 rm -f '$(DIR)'
113 install-common: deb-checkdir deb-checkuid config.status 118 rm *.o
114 rm -f '$(DIR)'
115 $(MAKE) clean
116 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert" MULTI=1 119 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert" MULTI=1
117 install -d -m0755 '$(DIR)'/usr/bin 120 install -d -m0755 '$(DIR)'/usr/bin
118 install -d -m0755 '$(DIR)'/usr/lib/dropbear 121 install -d -m0755 '$(DIR)'/usr/lib/dropbear
119 install -m0755 dropbearmulti \ 122 install -m0755 dropbearmulti \
120 '$(DIR)'/usr/lib/dropbear/dropbearmulti 123 '$(DIR)'/usr/lib/dropbear/dropbearmulti
124 for i in dropbearkey.8; do \ 127 for i in dropbearkey.8; do \
125 install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \ 128 install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \
126 done 129 done
127 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 130 gzip -9 '$(DIR)'/usr/share/man/man8/*.8
128 $(STRIP) -R .comment -R .note \ 131 $(STRIP) -R .comment -R .note \
129 '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* 132 '$(DIR)'/usr/lib/dropbear/*
130 133
131 install -d -m0755 '$(DIR)'/DEBIAN 134 install -d -m0755 '$(DIR)'/DEBIAN
132 test '$(CC)' != 'gcc' || \ 135 test '$(CC)' != 'gcc' || \
133 dpkg-shlibdeps '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* 136 dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
134 dpkg-gencontrol -isp -pdropbear-common -P'$(DIR)'
135 dpkg -b '$(DIR)' ..
136 137
137 install-scp: DIR=$(shell pwd)/debian/dropbear-scp 138 install-scp: DIR=$(shell pwd)/debian/dropbear-scp
138 install-scp: deb-checkdir deb-checkuid config.status 139 install-scp: deb-checkdir deb-checkuid config.status
139 rm -f '$(DIR)' 140 rm -f '$(DIR)'
140 $(MAKE) clean 141 rm *.o
141 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="scp" scp 142 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="scp" scp
142 install -d -m0755 '$(DIR)'/usr/bin 143 install -d -m0755 '$(DIR)'/usr/bin
143 install -m0755 scp '$(DIR)'/usr/bin/scp 144 install -m0755 scp '$(DIR)'/usr/bin/scp
144 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/* 145 $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/*
145 146
146 install -d -m0755 '$(DIR)'/DEBIAN 147 install -d -m0755 '$(DIR)'/DEBIAN
147 test '$(CC)' != 'gcc' || \ 148 test '$(CC)' != 'gcc' || \
148 dpkg-shlibdeps '$(DIR)'/usr/bin/* 149 dpkg-shlibdeps '$(DIR)'/usr/bin/*
149 dpkg-gencontrol -isp -pdropbear-scp -P'$(DIR)'
150 dpkg -b '$(DIR)' ..
151 150
152 install-multi: DIR=$(shell pwd)/debian/dropbear 151 install-multi: DIR=$(shell pwd)/debian/dropbear
153 install-multi: deb-checkdir deb-checkuid config.status 152 install-multi: deb-checkdir deb-checkuid config.status
154 rm -f '$(DIR)' 153 rm -f '$(DIR)'
155 $(MAKE) clean 154 rm *.o
156 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert scp dropbear dbclient" MULTI=1 155 $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert scp dropbear dbclient" MULTI=1
157 install -d -m0755 '$(DIR)'/etc/dropbear 156 install -d -m0755 '$(DIR)'/etc/dropbear
158 # programs 157 # programs
159 install -d -m0755 '$(DIR)'/usr/bin 158 install -d -m0755 '$(DIR)'/usr/bin
160 install -d -m0755 '$(DIR)'/usr/sbin 159 install -d -m0755 '$(DIR)'/usr/sbin
179 done 178 done
180 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 179 gzip -9 '$(DIR)'/usr/share/man/man8/*.8
181 install -d -m0755 '$(DIR)'/usr/share/man/man1 180 install -d -m0755 '$(DIR)'/usr/share/man/man1
182 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/ 181 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/
183 gzip -9 '$(DIR)'/usr/share/man/man1/*.1 182 gzip -9 '$(DIR)'/usr/share/man/man1/*.1
184 $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* \ 183 $(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
185 '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/* 184
186 185 install -d -m0755 '$(DIR)'/DEBIAN
187 install -d -m0755 '$(DIR)'/DEBIAN 186 test '$(CC)' != 'gcc' || \
188 test '$(CC)' != 'gcc' || \ 187 dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
189 dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \ 188
190 '$(DIR)'/usr/lib/dropbear/* 189 install: install-client install-server install-keyutils install-multi install-scp
191 dpkg-gencontrol -isp -pdropbear -P'$(DIR)'
192 dpkg -b '$(DIR)' ..
193
194 install: install-client install-server install-common install-multi install-scp
195 binary-indep: 190 binary-indep:
196 191
197 binary-arch: install dropbear.deb dropbear-server.deb dropbear-common.deb dropbear-scp.deb dropbear-client.deb 192 binary-arch: install dropbear.deb dropbear-server.deb dropbear-keyutils.deb dropbear-scp.deb dropbear-client.deb
193 dpkg-gencontrol -isp -pdropbear -P'$(shell pwd)/debian'/dropbear
194 dpkg-gencontrol -isp -pdropbear-server -P'$(shell pwd)/debian'/dropbear-server
195 dpkg-gencontrol -isp -pdropbear-client -P'$(shell pwd)/debian'/dropbear-client
196 dpkg-gencontrol -isp -pdropbear-keyutils -P'$(shell pwd)/debian'/dropbear-keyutils
197 dpkg-gencontrol -isp -pdropbear-scp -P'$(shell pwd)/debian'/dropbear-scp
198 dpkg -b '$(shell pwd)/debian'/dropbear ..
199 dpkg -b '$(shell pwd)/debian'/dropbear-server ..
200 dpkg -b '$(shell pwd)/debian'/dropbear-keyutils ..
201 dpkg -b '$(shell pwd)/debian'/dropbear-scp ..
202 dpkg -b '$(shell pwd)/debian'/dropbear-client ..
198 203
199 binary: binary-arch binary-indep 204 binary: binary-arch binary-indep
200 205
201 .PHONY: patch build clean install binary-indep binary-arch binary 206 .PHONY: patch build clean install binary-indep binary-arch binary
202 207