comparison debian/rules @ 823:cb3cfcea1c8d

Fix debian installation of manpages
author Matt Johnston <matt@ucc.asn.au>
date Fri, 04 Oct 2013 21:49:32 +0800
parents 8c2d2edadf2a
children 7b68e581985f
comparison
equal deleted inserted replaced
822:32862e8283e7 823:cb3cfcea1c8d
77 install -d -m0755 '$(DIR)'/etc/dropbear/log 77 install -d -m0755 '$(DIR)'/etc/dropbear/log
78 install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run 78 install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run
79 ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main 79 ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main
80 # man pages 80 # man pages
81 install -d -m0755 '$(DIR)'/usr/share/man/man8 81 install -d -m0755 '$(DIR)'/usr/share/man/man8
82 for i in dropbear.8 dropbearkey.8; do \ 82 install -d -m0755 '$(DIR)'/usr/share/man/man1
83 install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \ 83 install -m644 dropbear.8 '$(DIR)'/usr/share/man/man8/
84 for i in dbclient.1 dropbearkey.1 dropbearconvert.1; do \
85 install -m644 $$i '$(DIR)'/usr/share/man/man1/ || exit 1; \
84 done 86 done
85 gzip -9 '$(DIR)'/usr/share/man/man8/*.8 87 gzip -9 '$(DIR)'/usr/share/man/man8/*.8
86 install -d -m0755 '$(DIR)'/usr/share/man/man1
87 install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/
88 gzip -9 '$(DIR)'/usr/share/man/man1/*.1 88 gzip -9 '$(DIR)'/usr/share/man/man1/*.1
89 # copyright, changelog 89 # copyright, changelog
90 cat debian/copyright.in LICENSE >debian/copyright 90 cat debian/copyright.in LICENSE >debian/copyright
91 test -r changelog || ln -s CHANGES changelog 91 test -r changelog || ln -s CHANGES changelog
92 92