diff configure.ac @ 865:39d872718d4b

Try and fix utmp handling
author Matt Johnston <matt@ucc.asn.au>
date Mon, 25 Nov 2013 23:30:01 +0800
parents 30ab30e46452
children 12d5f40894ec
line wrap: on
line diff
--- a/configure.ac	Mon Nov 25 23:08:33 2013 +0800
+++ b/configure.ac	Mon Nov 25 23:30:01 2013 +0800
@@ -540,7 +540,9 @@
 AC_MSG_CHECKING([if your system defines WTMP_FILE])
 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
 #include <sys/types.h>
-#include <utmp.h>
+#ifdef HAVE_UTMP_H
+#  include <utmp.h>
+#endif
 #ifdef HAVE_PATHS_H
 #  include <paths.h>
 #endif
@@ -598,9 +600,11 @@
 AC_MSG_CHECKING([if your system defines WTMPX_FILE])
 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
 #include <sys/types.h>
-#include <utmp.h>
+#ifdef HAVE_UTMP_H
+#  include <utmp.h>
+#endif
 #ifdef HAVE_UTMPX_H
-#include <utmpx.h>
+#  include <utmpx.h>
 #endif
 #ifdef HAVE_PATHS_H
 #  include <paths.h>