diff configure.ac @ 928:7cd89d4e0335

Add new monotonic_now() wrapper so that timeouts are unaffected by system clock changes
author Matt Johnston <matt@ucc.asn.au>
date Thu, 13 Mar 2014 23:50:09 +0800
parents 4f1988cb79ce
children 3a32727986ee
line wrap: on
line diff
--- a/configure.ac	Thu Mar 13 23:08:47 2014 +0800
+++ b/configure.ac	Thu Mar 13 23:50:09 2014 +0800
@@ -361,6 +361,10 @@
 AC_CHECK_FUNCS(setutxent utmpxname)
 AC_CHECK_FUNCS(logout updwtmp logwtmp)
 
+# OS X monotonic time
+AC_CHECK_HEADERS([mach/mach_time.h])
+AC_CHECK_FUNCS(mach_absolute_time)
+
 AC_ARG_ENABLE(bundled-libtom,
 [  --enable-bundled-libtom       Force using bundled libtomcrypt/libtommath even if a system version exists.
   --disable-bundled-libtom      Force using system libtomcrypt/libtommath, fail if it does not exist.