diff configure.ac @ 1798:8dc43b30c6bf

Define _GNU_SOURCE properly, other header fixes This lets -std=c89 build for gcc 8.4.0
author Matt Johnston <matt@ucc.asn.au>
date Thu, 04 Mar 2021 21:03:02 +0800
parents d5680e12ac33
children 7dc92355a986
line wrap: on
line diff
--- a/configure.ac	Thu Mar 04 21:02:16 2021 +0800
+++ b/configure.ac	Thu Mar 04 21:03:02 2021 +0800
@@ -47,6 +47,9 @@
 AC_MSG_NOTICE([Checking if compiler '$CC' supports -fno-strict-overflow])
 DB_TRYADDCFLAGS([-fno-strict-overflow])
 
+# needed for various extensions. define early before autoconf tests
+AC_DEFINE([_GNU_SOURCE], [], [Use GNU extensions if glibc])
+
 STATIC=0
 AC_ARG_ENABLE(static,
 	[  --enable-static         Build static binaries],