diff debian/rules @ 527:9f5e2616c064 maemo

- 0.52-2, put key utils into -server package
author Matt Johnston <matt@ucc.asn.au>
date Wed, 19 Nov 2008 13:53:41 +0000
parents 3c3cef8a32e6
children 7f552ea5bf72
line wrap: on
line diff
--- a/debian/rules	Wed Nov 19 12:03:57 2008 +0000
+++ b/debian/rules	Wed Nov 19 13:53:41 2008 +0000
@@ -37,6 +37,7 @@
 	    --build='$(DEB_BUILD_GNU_TYPE)' --prefix=/usr \
 	    --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \
 	    $(CONFFLAGS)
+	$(MAKE) clean
 
 build: deb-checkdir build-stamp
 build-stamp: config.status
@@ -55,19 +56,25 @@
 	rm -rf '$(DIR)'
 	rm -rf '$(DIR)'-client
 	rm -rf '$(DIR)'-server
-	rm -rf '$(DIR)'-common
+	rm -rf '$(DIR)'-keyutils
 	rm -rf '$(DIR)'-scp
 	rm -f debian/files debian/substvars debian/copyright changelog
 
 install-server: DIR=$(shell pwd)/debian/dropbear-server
 install-server: deb-checkdir deb-checkuid config.status 
 	rm -f '$(DIR)'
-	$(MAKE) clean
-	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dropbear dropbear
+	rm *.o
+	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbear dropbearkey dropbearconvert" MULTI=1
 	install -d -m0755 '$(DIR)'/etc/dropbear
 	# programs
+	install -d -m0755 '$(DIR)'/usr/bin
 	install -d -m0755 '$(DIR)'/usr/sbin
-	install -m0755 dropbear '$(DIR)'/usr/sbin/dropbear
+	install -d -m0755 '$(DIR)'/usr/lib/dropbear
+	install -m0755 dropbearmulti \
+	  '$(DIR)'/usr/lib/dropbear/dropbearmulti
+	ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dropbearkey
+	ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/sbin/dropbear
+	ln -s dropbearmulti '$(DIR)'/usr/lib/dropbear/dropbearconvert
 	# init and run scripts
 	install -d -m0755 '$(DIR)'/etc/init.d
 	install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear
@@ -83,16 +90,16 @@
 	# copyright, changelog
 	cat debian/copyright.in LICENSE > debian/copyright
 	test -r changelog || ln -s CHANGES changelog
-	$(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/*
+	$(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
 
 	install -d -m0755 '$(DIR)'/DEBIAN
 	test '$(CC)' != 'gcc' || \
-	  dpkg-shlibdeps '$(DIR)'/usr/sbin/*
+	  dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
 
 install-client: DIR=$(shell pwd)/debian/dropbear-client
 install-client: deb-checkdir deb-checkuid config.status 
 	rm -f '$(DIR)'
-	$(MAKE) clean
+	rm *.o
 	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dbclient dbclient
 	install -d -m0755 '$(DIR)'/usr/bin
 	install -m0755 dbclient '$(DIR)'/usr/bin/dbclient
@@ -105,10 +112,10 @@
 	test '$(CC)' != 'gcc' || \
 	  dpkg-shlibdeps  '$(DIR)'/usr/bin/*
 
-install-common: DIR=$(shell pwd)/debian/dropbear-common
-install-common: deb-checkdir deb-checkuid config.status 
+install-keyutils: DIR=$(shell pwd)/debian/dropbear-keyutils
+install-keyutils: deb-checkdir deb-checkuid config.status 
 	rm -f '$(DIR)'
-	$(MAKE) clean
+	rm *.o
 	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert" MULTI=1
 	install -d -m0755 '$(DIR)'/usr/bin
 	install -d -m0755 '$(DIR)'/usr/lib/dropbear
@@ -122,16 +129,16 @@
 	done
 	gzip -9 '$(DIR)'/usr/share/man/man8/*.8
 	$(STRIP) -R .comment -R .note \
-	  '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/*
+	   '$(DIR)'/usr/lib/dropbear/*
 
 	install -d -m0755 '$(DIR)'/DEBIAN
 	test '$(CC)' != 'gcc' || \
-	  dpkg-shlibdeps '$(DIR)'/usr/bin/*  '$(DIR)'/usr/lib/dropbear/*
+	  dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
 
 install-scp: DIR=$(shell pwd)/debian/dropbear-scp
 install-scp: deb-checkdir deb-checkuid config.status 
 	rm -f '$(DIR)'
-	$(MAKE) clean
+	rm *.o
 	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="scp" scp 
 	install -d -m0755 '$(DIR)'/usr/bin
 	install -m0755 scp '$(DIR)'/usr/bin/scp
@@ -144,7 +151,7 @@
 install-multi: DIR=$(shell pwd)/debian/dropbear
 install-multi: deb-checkdir deb-checkuid config.status 
 	rm -f '$(DIR)'
-	$(MAKE) clean
+	rm *.o
 	$(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert scp dropbear dbclient" MULTI=1
 	install -d -m0755 '$(DIR)'/etc/dropbear
 	# programs
@@ -173,26 +180,24 @@
 	install -d -m0755 '$(DIR)'/usr/share/man/man1
 	install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/
 	gzip -9 '$(DIR)'/usr/share/man/man1/*.1
-	$(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* \
-	  '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/*
+	$(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
 
 	install -d -m0755 '$(DIR)'/DEBIAN
 	test '$(CC)' != 'gcc' || \
-	  dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \
-	    '$(DIR)'/usr/lib/dropbear/*
+	  dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
 
-install: install-client install-server install-common install-multi install-scp
+install: install-client install-server install-keyutils install-multi install-scp
 binary-indep:
 
-binary-arch: install dropbear.deb dropbear-server.deb dropbear-common.deb dropbear-scp.deb dropbear-client.deb
+binary-arch: install dropbear.deb dropbear-server.deb dropbear-keyutils.deb dropbear-scp.deb dropbear-client.deb
 	dpkg-gencontrol -isp -pdropbear -P'$(shell pwd)/debian'/dropbear
 	dpkg-gencontrol -isp -pdropbear-server -P'$(shell pwd)/debian'/dropbear-server
 	dpkg-gencontrol -isp -pdropbear-client -P'$(shell pwd)/debian'/dropbear-client
-	dpkg-gencontrol -isp -pdropbear-common -P'$(shell pwd)/debian'/dropbear-common
+	dpkg-gencontrol -isp -pdropbear-keyutils -P'$(shell pwd)/debian'/dropbear-keyutils
 	dpkg-gencontrol -isp -pdropbear-scp -P'$(shell pwd)/debian'/dropbear-scp
 	dpkg -b '$(shell pwd)/debian'/dropbear ..
 	dpkg -b '$(shell pwd)/debian'/dropbear-server ..
-	dpkg -b '$(shell pwd)/debian'/dropbear-common ..
+	dpkg -b '$(shell pwd)/debian'/dropbear-keyutils ..
 	dpkg -b '$(shell pwd)/debian'/dropbear-scp ..
 	dpkg -b '$(shell pwd)/debian'/dropbear-client ..