diff configure.ac @ 1510:eb4c7052f51d coverity

merge coverity up to date
author Matt Johnston <matt@ucc.asn.au>
date Sat, 17 Feb 2018 11:29:17 +0800
parents 55120acb9994
children 5916af64acd4 93a3726a36d6
line wrap: on
line diff
--- a/configure.ac	Sat Feb 10 19:06:13 2018 +0800
+++ b/configure.ac	Sat Feb 17 11:29:17 2018 +0800
@@ -11,7 +11,6 @@
 
 # Checks for programs.
 AC_PROG_CC
-AC_PROG_MAKE_SET
 
 if test -z "$LD" ; then
 	LD=$CC
@@ -111,6 +110,11 @@
 	    )
 	# FORTIFY_SOURCE
 	DB_TRYADDCFLAGS([-D_FORTIFY_SOURCE=2])
+
+	# Spectre v2 mitigations
+	DB_TRYADDCFLAGS([-mfunction-return=thunk])
+	DB_TRYADDCFLAGS([-mindirect-branch=thunk])
+
 fi
 
 # large file support is useful for scp