Mercurial > dropbear
view debian/dropbear.postinst @ 437:7319d229799a
0.49 probably done
author | Matt Johnston <matt@ucc.asn.au> |
---|---|
date | Thu, 22 Feb 2007 15:46:57 +0000 |
parents | 654bc8327787 |
children | c23c7f0f594c |
line wrap: on
line source
#!/bin/sh set -e test "$1" = 'configure' || exit 0 if test ! -e /etc/dropbear/dropbear_rsa_host_key; then if test -f /etc/ssh/ssh_host_rsa_key; then echo "Converting existing OpenSSH RSA host key to Dropbear format." /usr/lib/dropbear/dropbearconvert openssh dropbear \ /etc/ssh/ssh_host_rsa_key /etc/dropbear/dropbear_rsa_host_key else echo "Generating Dropbear RSA key. Please wait." dropbearkey -t rsa -f /etc/dropbear/dropbear_rsa_host_key fi fi if test ! -e /etc/dropbear/dropbear_dss_host_key; then if test -f /etc/ssh/ssh_host_dsa_key; then echo "Converting existing OpenSSH RSA host key to Dropbear format." /usr/lib/dropbear/dropbearconvert openssh dropbear \ /etc/ssh/ssh_host_dsa_key /etc/dropbear/dropbear_dss_host_key else echo "Generating Dropbear DSS key. Please wait." dropbearkey -t dss -f /etc/dropbear/dropbear_dss_host_key fi fi if test ! -s /etc/default/dropbear; then # check whether OpenSSH seems to be installed. if test -x /usr/sbin/sshd; then cat <<EOT OpenSSH appears to be installed. Setting /etc/default/dropbear so that Dropbear will not start by default. Edit this file to change this behaviour. EOT cat >>/etc/default/dropbear <<EOT # disabled because OpenSSH is installed # change to NO_START=0 to enable Dropbear NO_START=1 EOT fi cat >>/etc/default/dropbear <<EOT # the TCP port that Dropbear listens on DROPBEAR_PORT=22 # any additional arguments for Dropbear DROPBEAR_EXTRA_ARGS= # specify an optional banner file containing a message to be # sent to clients before they connect, such as "/etc/issue.net" DROPBEAR_BANNER="" # RSA hostkey file (default: /etc/dropbear/dropbear_rsa_host_key) #DROPBEAR_RSAKEY="/etc/dropbear/dropbear_rsa_host_key" # DSS hostkey file (default: /etc/dropbear/dropbear_dss_host_key) #DROPBEAR_DSSKEY="/etc/dropbear/dropbear_dss_host_key" EOT fi if test -x /etc/init.d/dropbear; then update-rc.d dropbear defaults >/dev/null if test -x /usr/sbin/invoke-rc.d; then invoke-rc.d dropbear restart else /etc/init.d/dropbear restart fi fi