diff rust/Cargo.toml @ 639:89818a14648b rust tip

- switch to using anyhow for errors, surf for http runs but surf has problems
author Matt Johnston <matt@ucc.asn.au>
date Thu, 28 Nov 2019 23:57:00 +0800
parents 1e147b3c2c55
children
line wrap: on
line diff
--- a/rust/Cargo.toml	Sat Nov 09 11:35:59 2019 +0800
+++ b/rust/Cargo.toml	Thu Nov 28 23:57:00 2019 +0800
@@ -22,9 +22,14 @@
 anyhow = "1.0"
 
 # alpha for async
-hyper = "=0.13.0-alpha.1"
-futures-preview = "=0.3.0-alpha.18"
-futures-util-preview = "=0.3.0-alpha.18"
+futures = "0.3"
+#futures = "=0.3.0-alpha.18"
+#futures-util-preview = "=0.3.0-alpha.18"
+
+async-std = "0.99"
+# XXX use hyper-client to workaround https://github.com/http-rs/surf/issues/72
+# surf = { version = "1.0", features = ["hyper-client"] }
+surf = "1.0"
 
 [target.'cfg(target_os = "linux")'.dependencies]
 sysfs_gpio = "0.5"