diff rust/Cargo.toml @ 631:c57821a60e51 rust

rust work in progress ?
author Matt Johnston <matt@ucc.asn.au>
date Sat, 06 Jul 2019 18:28:34 +0800
parents d5075136442f
children bde302def78e
line wrap: on
line diff
--- a/rust/Cargo.toml	Fri Apr 19 13:58:56 2019 +0800
+++ b/rust/Cargo.toml	Sat Jul 06 18:28:34 2019 +0800
@@ -2,11 +2,9 @@
 name = "wort-templog"
 version = "0.1.0"
 authors = ["Matt Johnston <[email protected]>"]
+edition = "2018"
 
 [dependencies]
-futures = "0.1"
-futures-cpupool = "0.1"
-tokio-core = "0.1"
 serde = "0.9"
 serde_derive = "0.9"
 rand = "0.3"
@@ -23,7 +21,7 @@
 base64 = "0.4"
 libc = "0.2"
 atomicwrites = "0.1"
-futures-await = "0.1"
+actix = "0.8"
 
 [target.'cfg(target_os = "linux")'.dependencies]
 sysfs_gpio = "0.5"