diff rust/Cargo.toml @ 626:efcbe0d3afd6 rust

fix to work with hyper
author Matt Johnston <matt@ucc.asn.au>
date Wed, 06 Dec 2017 00:09:45 +0800
parents 2710649ab71e
children d5075136442f
line wrap: on
line diff
--- a/rust/Cargo.toml	Wed Dec 06 00:08:46 2017 +0800
+++ b/rust/Cargo.toml	Wed Dec 06 00:09:45 2017 +0800
@@ -17,14 +17,12 @@
 time = "0.1"
 lazy_static = "0.2"
 regex = "0.2"
-tokio-curl = "0.1"
 toml = "0.3"
-curl = "0.4"
+hyper = "0.11"
 serde_json = "0.9"
 base64 = "0.4"
 libc = "0.2"
 atomicwrites = "0.1"
 
-# linux only
-[target.linux.dependencies]
+[target.'cfg(target_os = "linux")'.dependencies]
 sysfs_gpio = "0.5"